On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Box Notes Inbox loading issue
Incident Report for Box
Resolved
No further impact has been observed. If you are still experiencing issues with your Box Notes' Inbox section in the sidebar, please let us know at https://support.box.com.
Posted 3 months ago. Aug 24, 2018 - 15:44 PDT
Monitoring
We have resolved the issue with the "Inbox" section of Box Notes and will now monitor to ensure no further impact is observed.
Posted 3 months ago. Aug 24, 2018 - 14:40 PDT
Update
We are still working to resolve the issue impacting the "Inbox" in Box Notes.

Most users at this time should no longer see issues loading the "Inbox". A small subset of users however may see longer than normal loading times.

Loading of the Box Note content itself and regular web app (Box.com) functions continue to be unaffected.
Posted 3 months ago. Aug 24, 2018 - 13:45 PDT
Identified
We have identified the cause of the "Inbox" issues in Box Notes and are working to resolve the issue. Most users at this time should no longer be seeing issues loading the "Inbox" in Box Notes.

Loading of the Box Note content itself and regular web app (Box.com) functions continue to be unaffected.
Posted 3 months ago. Aug 24, 2018 - 12:30 PDT
Update
The "Inbox" section in Box Notes should be loading more quickly now for most users. We are continuing to investigate the cause of the "Inbox" issue.

Loading of the Box Note content itself and regular web app (Box.com) functions continue to be unaffected.
Posted 3 months ago. Aug 24, 2018 - 11:38 PDT
Investigating
We are currently investigating an issue affecting the "Inbox" section in the sidebar of Box Notes. Some users may see an error when attempting to load the "Inbox" or it may be slow to display.

Loading of the Box Note content itself is not affected nor are the regular web app (Box.com) functions affected.
Posted 3 months ago. Aug 24, 2018 - 10:47 PDT