Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some customers might notice problems around actions on newly uploaded files
Incident Report for Box
Resolved
Newly uploaded files are functioning normally as of 1:54 PM PDT.
Posted about 3 years ago. Oct 29, 2014 - 19:08 PDT
Monitoring
The issue that may have caused problems with actions surrounding newly uploaded content has been stabilized as of 1:54 PM PDT. Our teams are currently monitoring.
Posted about 3 years ago. Oct 29, 2014 - 13:54 PDT
Investigating
Since 12:41 PM PDT some customers may notice problems with actions surrounding newly uploaded content. We are currently investigating.
Posted about 3 years ago. Oct 29, 2014 - 12:41 PDT