About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Some users may be experiencing issues with Box Search
Incident Report for Box
Resolved
Box Engineers have confirmed that issues with Box Search are fully resolved. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help
Posted 12 months ago. Oct 31, 2017 - 12:40 PDT
Investigating
Box Engineering is currently investigating an issue with the Box Search service. Users may see issues using the search function.
Posted 12 months ago. Oct 31, 2017 - 11:28 PDT