Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Support.Box.Com is Unavailable for Some Customers
Incident Report for Box
Resolved
Resolved - Access to the Box Help site at https://support.box.com has been restored.
Posted over 2 years ago. Feb 02, 2015 - 06:39 PST
Identified
Identified - Some customers may be unable to access the Box Help site at https://support.box.com. We are actively working to restore access as soon as possible.
Posted over 2 years ago. Feb 02, 2015 - 05:26 PST