On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Box University Outage
Incident Report for Box
Resolved
We are able to confirm the issues with the Box University site have been resolved. Users should now be able to login to Box University and access their education/training material. If you are still seeing any issues, please let us know at https://support.box.com.
Posted 2 months ago. Oct 12, 2018 - 08:18 PDT
Update
We are continuing to work with our vendor to resolve the issues with the Box University site. The next update will be provided here when we can confirm all issues have been resolved.
Posted 2 months ago. Oct 11, 2018 - 17:07 PDT
Update
We are continuing to work with our vendor to resolve the issues with the Box University site. More updates will be provided here as soon as possible.
Posted 2 months ago. Oct 11, 2018 - 14:39 PDT
Identified
The third party vendor we use for Box University has reported an outage. We are working closely with the vendor to resolve the issue as soon as possible.
Posted 2 months ago. Oct 11, 2018 - 12:17 PDT
Investigating
We are investigating issues with Box University. User are unable to login currently. More information will be provided here as soon as possible. There is no impact to other Box services.
Posted 2 months ago. Oct 11, 2018 - 10:53 PDT
This incident affected: Box Community and Support Website (community.box.com) (Box University).