For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Outage] Issues with Box Services

Incident Report for Box

Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On September 4, 2025 between 11:03 AM and 11:24 AM PDT, Box was unavailable to users. The outage occurred when maintenance performed on our caching tier triggered a latent bug. We were able to remediate the issue by manually restoring the caching tier to its pre-maintenance state. After the initial issue was resolved, between 11:24 AM and 01:16 PM PDT, a limited number of users may have continued to experience slowness when interacting with some Box features. We resolved the latency issue by recreating the impacted customer instances. In addition, we are working to fix the bug, add error handling, and improve our maintenance processes to prevent similar issues from occurring in the future.

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Sep 05, 2025 - 15:59 PDT

Resolved

After further monitoring, this incident is now considered resolved. All services have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Sep 04, 2025 - 13:00 PDT

Update

Box services have recovered. We're continuing to monitor and ensure full restoration.
Posted Sep 04, 2025 - 12:12 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2025 - 11:45 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2025 - 11:33 PDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 11:28 PDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 11:23 PDT

Investigating

We are investigating an ongoing issue affecting Box. Users may experience errors or long load times using Box services. We will provide more information as soon as it is available.
Posted Sep 04, 2025 - 11:20 PDT
This incident affected: Box Platform / API (Content API, Content Preview, Authentication (OAuth 2.0 / JWT), Search, Uploads/Downloads, Webhooks, Box Embed Widget, Box Sign, Box Canvas, Workflows and Automations, Box Shuttle, Box AI, Box Doc Gen, Box Apps), Box Web Application (Login/SSO, Uploads/Downloads, Collaboration, Search, Preview, Sharing (Shared Links), Email Notifications, Admin Console & Functionality, Governance (Retention), Governance (Legal Holds), Workflows and Automations, Comments and Tasks, Accessible Site (a.box.com), Box Sign, Box Canvas, Box Shield (Threat Detection), Box Shield (Virus Detection), Box Shield (Auto Classification), Box Shuttle, Watermarking, Box Hubs, Box AI, Enterprise Reports, Box Forms, Box Doc Gen, Box AI Studio, Box Archive), Desktop Applications (Login/SSO, Box Sync, Box Drive, Box Edit / Tools), Mobile Applications (Login/SSO, Preview, Search, Uploads/Downloads, Mobile-Optimized Website (m.box.com)), Partners / Integrations (Microsoft Online, Apple iWork, Box for Salesforce, Google Apps, NetSuite, Microsoft Teams, Slack), Box Community and Support Website (community.box.com) (Case Submission Workflow, Blog Posts and Knowledge Articles, Community Forums, Box University), Box Notes (Web Application), Box Zones (Australia, Canada, France, Germany, Ireland, Japan, Singapore, UK, US), and Box Relay, Developer Console / Docs (developer.box.com), FTP, Box Website.