Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Some users unable to log in to Box Mobile Website
Incident Report for Box
Resolved
We have not seen any further issues with the Box Mobile Website. If you experience any problems, please contact us at https://support.box.com
Posted over 2 years ago. Jun 09, 2015 - 14:27 PDT
Monitoring
The issue has been resolved, and the Box Mobile Website should be fully accessible at this point. We will continue to monitor. If you have any issues, please reach out to us at https://support.box.com
Posted over 2 years ago. Jun 09, 2015 - 12:36 PDT
Investigating
Some users may be experiencing an error "Sorry, we couldn't load Box" when attempting to log in to the mobile web site. We are currently investigating the issue.
Posted over 2 years ago. Jun 09, 2015 - 11:30 PDT
This incident affected: Mobile.