On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Medium] Issues loading multiple Box services
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you are still receiving any unexpected 429 errors when using Box, please reach out to us at https://support.box.com.
Posted 3 months ago. Aug 14, 2018 - 15:24 PDT
Monitoring
We have identified and resolved the underlying issue that caused the loading issues earlier today with core Box services. We are now monitoring to ensure no further impact is observed.
Posted 3 months ago. Aug 14, 2018 - 13:36 PDT
Update
We have taken actions to remediate the issue and users should be able to access Box services again. We are continuing to investigate the cause of the issue.
Posted 3 months ago. Aug 14, 2018 - 12:40 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Aug 14, 2018 - 12:34 PDT
Update
Users may also see issues loading Box.com and other core Box services. We are investigating the issue and will update here as soon as we have additional information
Posted 3 months ago. Aug 14, 2018 - 12:30 PDT
Investigating
We are investigating an issue with loading Box Notes. Some users may see a 429 error when attempting to access a Box Note.
Posted 3 months ago. Aug 14, 2018 - 12:26 PDT
This incident affected: Box Platform / API (Content API, Content Preview), Desktop Applications (Box Sync, Box Drive), Box Web Application (Email Notifications), and FTP, WebDAV.