For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Outage] Issues with Multiple Box Services

Incident Report for Box

Postmortem

We recently experienced issues affecting customers’ access to their files, including uploads, downloads, preview and Box Notes. We would like to take the opportunity to further explain these issues and the steps we have taken to improve our resilience in the future.

Between 10:50 AM and 1:10 PM PT on June 12th, 2025, users experienced difficulties while working in Box. While customers were able to log in and browse their account during this time, features that deal directly with file content, such as uploads, downloads and preview, were unavailable. This was due to a global outage affecting critical third-party cloud services on which Box relies.

Timeline

The following is a high-level timeline of the incident:

  • 10:50 am: The cloud services in question suffered a worldwide outage rendering file content owned by our customers inaccessible. Incident response commences both at Box and within affected cloud service provider organizations.
  • 12:30 pm: Third party cloud services are partially recovered, and service becomes available in some regions.
  • 1:10 pm: Box engineers complete regional failover of file content traffic into a region where cloud service has been recovered. Box customer impact is mitigated at this point.
  • 2:23 pm: Cloud services are fully recovered.

Analysis

Box systems are designed to be resilient to outages and degradations in our cloud environment. In particular, we design our systems to handle zonal and single-region cloud service incidents with minimal impact to our customers. Unfortunately, this incident was caused by a global cloud service provider issue that caused service to remain offline across all cloud regions for a prolonged period of time. Box architects our systems to be resilient to a wide variety of incidents with minimal impact to customers. Given that this incident was exceedingly rare and global, the impact to our systems was more prolonged.

However, our prompt reaction to the incident reduced impact for Box customers by 73 minutes relative to the total length of outage suffered by our cloud service provider. That said, we take every incident as a learning opportunity and have surfaced additional improvements we can make to our systems and procedures.

Corrective Actions

Box has initiated the following corrective actions:

  • Box’s communications with underlying cloud service providers will be improved for more rapid incident resolution. In this case, cloud services were recovered in a region, but we were not immediately alerted so it took some time for Box engineers to discover this and route traffic to it. We are working to improve our joint incident response protocols with third party cloud service providers to address this.
  • As part of our analysis on this incident, we discovered opportunities for deeper third party integrations that will enable us to further improve our automatic recovery in the unlikely event that such an event occurs again. This will lessen our dependence on direct communication with vendors.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Jun 13, 2025 - 14:13 PDT

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jun 12, 2025 - 17:43 PDT

Update

We are continuing to monitor for any additional impact.
Posted Jun 12, 2025 - 15:34 PDT

Update

All of our services are performing at robust levels. We continue to actively monitor our services.
Posted Jun 12, 2025 - 14:20 PDT

Monitoring

Our cloud service provider has mostly recovered and we are working to continually bring services back and are in communication with our provider around full recovery of the services impacted.
Posted Jun 12, 2025 - 13:18 PDT

Identified

Due to the ongoing Google cloud (https://status.cloud.google.com/) issues, Box services like Notes, Uploads and Downloads are seeing significant impact. We have actively engaged with our Cloud service provider and are partnering with them to prioritize recovery of our services, In parallel, we continue investigating all means possible to provide a prompt recovery of our services
Posted Jun 12, 2025 - 12:04 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 11:37 PDT

Investigating

Our team is investigating an issue with Box Notes. Users may see errors or slowness when attempting to utilize Box Notes. We will provide additional information as it becomes available.
Posted Jun 12, 2025 - 11:19 PDT
This incident affected: Box Platform / API (Content API, Content Preview, Uploads/Downloads), Box Notes (Web Application), and Box Web Application (Uploads/Downloads, Preview, Admin Console & Functionality).