Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

New User Sign Ups May Not Work
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com
Posted 7 months ago. Jan 10, 2017 - 15:04 PST
Monitoring
Box Engineers have remediated the issue, and sign ups should be working again as expected. We will monitor to ensure no further issues.
Posted 7 months ago. Jan 10, 2017 - 14:43 PST
Identified
New users signing up for Box may be unable to sign up. Our engineers have identified the issue and are working to resolve it.
Posted 7 months ago. Jan 10, 2017 - 14:27 PST
Investigating
New users signing up for Box may be unable to sign up. Our engineers are currently investigating the issue.
Posted 7 months ago. Jan 10, 2017 - 14:12 PST
This incident affected: Box Website.