Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Intermittent Connection Issues to Box Web App
Incident Report for Box
Resolved
The issue with connections to the Box Web App has been resolved. Please report any new issues to https://support.box.com.
Posted over 2 years ago. Apr 02, 2015 - 12:27 PDT
Monitoring
Box Engineering Teams have restored stability to the Web App. Please log any new issues to https://support.box.com.
Posted over 2 years ago. Apr 02, 2015 - 11:41 PDT
Investigating
Some users are experiencing intermittent connectivity issue to the Box Web App. Box Engineering Teams are actively investigating.
Posted over 2 years ago. Apr 02, 2015 - 11:29 PDT
This incident affected: Box Website and Box Notes.