Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Some Spain-Based Users Unable to Access Box
Incident Report for Box
Resolved
UPDATE 24-Sep-15 11:00am PDT: We have confirmation from users of Telefonica/Movistar that the issue has been resolved by the ISP in Spain.

UPDATE 23-Sep-15 12:30pm PDT: We have determined this issue is being caused by Telefonica/Movistar, and we are reaching out to their NOC for resolution.
As a workaround: Users in Spain can access Box through some alternate Box domains. Please contact us at https://community.box.com/t5/Help/ct-p/Support and we can share the domains via a Support Case.

UPDATE: This access issue with Spain-based users continues due to some issues with Telefonica/Movistar ISP.

If you continue to see issues with connecting from Spain please report this issue directly to your ISP. The Box services are functioning normally.
Posted about 2 years ago. Sep 22, 2015 - 20:00 PDT
Investigating
Our Network Operations team has identified an issue with the Telefonica/Movistar ISP that is preventing some users in Spain from connecting to the Box services - Web, Mobile, and Sync. While our internal teams investigate the issue and potential workarounds, we would also ask that you report this issue directly to the ISP to identify any connectivity issues within the network.
Posted about 2 years ago. Sep 22, 2015 - 12:30 PDT
This incident affected: Box Website.