For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Multiple Box Services

Incident Report for Box

Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On April 13, 2025 between 4:29PM and 7:14PM PDT, some users may have experienced difficulties while working in Box. During this time, users may have experienced slowness or occasional errors when interacting with some features in the Box webapp or public API, including Logins, Uploads/Downloads, and Notes. The issue occurred when multiple instances of our relational data access service in a single availability zone started to experience higher-than-expected latencies. We were able to resolve the issue by performing a rolling restart of the affected instances, which removed the additional latencies. In addition, we are actively investigating the cause of the additional latencies to prevent similar issues from occurring in the future as well as improving the rolling restart execution time to decrease remediation time if a similar issue occurs again. 

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Apr 23, 2025 - 17:18 PDT

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 19:30 PDT

Update

After further monitoring, this incident is now considered resolved. All services have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Apr 13, 2025 - 19:30 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2025 - 19:11 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2025 - 18:38 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 13, 2025 - 17:43 PDT

Investigating

We are investigating an ongoing issue affecting the Box API, uploads, downloads, logins, and Box Notes. We will provide more information as soon as it is available.
Posted Apr 13, 2025 - 17:24 PDT
This incident affected: Box Platform / API (Content API, Uploads/Downloads), Box Web Application (Login/SSO, Uploads/Downloads), and Box Notes (Web Application).