Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 26, 2015 - 15:30 PST
Monitoring
SSO sign-in is now available for Box users. We will continue to monitor for any outages. If you are experiencing issues, please contact us at support.box.com
Posted almost 2 years ago. Feb 26, 2015 - 14:09 PST
Update
Login to Box Web Application and on mobile is remediated and available to users. However SSO-logins are unavailable. We are actively bringing back SSO-logins.
Posted almost 2 years ago. Feb 26, 2015 - 13:18 PST
Update
Box Web Application is available for users that have previously logged in. Users that are signing in recently (without a valid cookie) will still be having trouble logging into the web application. We are working on resolving the issue as soon as possible.
Posted almost 2 years ago. Feb 26, 2015 - 13:06 PST
Identified
We have identified that the Box Web Application may be unavailable for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted almost 2 years ago. Feb 26, 2015 - 12:49 PST
This incident affected: Box Website.