Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues accessing Box
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com
Posted 4 months ago. Dec 21, 2016 - 13:00 PST
Monitoring
Access to Box has been restored. Box engineering teams are continuing to monitor services to ensure no further impact.
Posted 4 months ago. Dec 21, 2016 - 12:07 PST
Identified
Box Engineers have isolated the suspected cause of the current event and are actively taking steps to remediate.
Posted 4 months ago. Dec 21, 2016 - 12:03 PST
Investigating
Some users may be experiencing issues while accessing box.com. Our engineering team is currently investigating.
Posted 4 months ago. Dec 21, 2016 - 11:51 PST
This incident affected: Box Website, Box Notes, Box Sync, Content Preview, Content API, View API, Downloads, Uploads, Email Notifications, Search, Sharing, Mobile, Metadata, WebDAV, and FTP.