Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Intermittent Access Issues to Box Services
Incident Report for Box
Resolved
All systems are stable at this point, the issue is now resolved.
Posted about 1 year ago. Jan 21, 2016 - 16:07 PST
Monitoring
All Box Services are stable, and we are continuing to monitor the situation to ensure no further problems arise.
Posted about 1 year ago. Jan 21, 2016 - 11:48 PST
Identified
The monitoring period passed and we have not gotten back to fully normal behavior.

Our engineers have identified the root of the issue and are working to resolve it now.
Posted about 1 year ago. Jan 21, 2016 - 07:30 PST
Monitoring
Our engineers have resolved the issue, and are monitoring the situation to ensure no further problems arise.
Posted about 1 year ago. Jan 21, 2016 - 02:59 PST
Identified
Our engineers have identified the root of the issue and are working to resolve it now.
Posted about 1 year ago. Jan 21, 2016 - 01:49 PST
Investigating
Our engineers are currently investigating an issue which could lead to intermittent issues accessing the Box web app and Box Services.
Posted about 1 year ago. Jan 20, 2016 - 23:00 PST
This incident affected: Box Website.