Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues with Box Notes and Uploads
Incident Report for Box
Resolved
The monitoring period has ended and no further issues have been observed. Please report any outstanding issues to Box User Services via https://community.box.com/help
Posted about 1 year ago. Jun 20, 2016 - 17:00 PDT
Monitoring
Box engineers have stabilized affected services. We are currently monitoring to ensure no further impact from this event.
Posted about 1 year ago. Jun 20, 2016 - 16:35 PDT
Investigating
Some Box users may experience intermittent issues loading and opening Box Notes, as well as uploading files to Box. Box engineers are working on resolving the issue.
Posted about 1 year ago. Jun 20, 2016 - 16:04 PDT
This incident affected: Box Notes and Uploads.