Error Submitting Support Cases on the Box Community
Incident Report for Box
Resolved
We have resolved the issues that prevented support cases from being raised on the Box Community and Support site. We will monitor to ensure no further impact is observed, though do not expect any further impact.
Posted 4 months ago. May 23, 2018 - 08:28 PDT
Identified
We have identified an issue impacting the Box Community and Support site. Users attempting to submit a web form case may see an error during the submission workflow preventing the case from being recorded. In addition, some users are unable to view their full list of support cases. We are working with our vendor to address this issue and expect to see this resolved soon. Alternate support channels are still available at https://support.box.com
Posted 4 months ago. May 23, 2018 - 08:14 PDT