For more informtion about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Downloads in Asia-Pacific and Middle East regions may be slow for some users
Incident Report for Box
Postmortem
Notice and disclaimer: Customer understands and agrees that this is preliminary information subject to further review and analysis by Box. To the best of our knowledge, this is the current state AND WILL BE UPDATED as more information is confirmed.
LAST UPDATED: April 14, 2020

We recently addressed issues affecting downloads from Box and would like to take the opportunity to further explain these issues and the steps taken to remediate them.

Between 03/16/2020 12:30am PDT and 03/22/2020 10:14am PDT, some users may have experienced difficulties while working in Box. During this time, customers would have experienced slow or stalled downloads. The issue occurred as a result of unusual strain on our systems. We were able to resolve the issue by disabling the traffic pattern in question and increasing capacity on our systems. In addition, we have implemented new monitoring to prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Apr 14, 2020 - 16:05 PDT

Resolved
No additional impact has been observed and this incident is now considered Resolved. Please contact Box Support at https://support.box.com if you experience any additional issues.
Posted Mar 23, 2020 - 17:17 PDT
Monitoring
Our Engineering Team has mitigated issues with our Japan PoP and have successfully redirected all traffic in the region back to its previous state. At this time, the performance for Middle East and Asia Pacific customers is restored. We will continue to monitor and provide updates at any change in status.
Posted Mar 22, 2020 - 11:36 PDT
Update
Our Engineering team is continuing their investigation. The identified impact remains isolated to some users in the Asia-Pacific and Middle East regions. The impact to downloads is a result of a temporary redirection of traffic to our US data centers while we mitigate an issue with our Japan PoP. We apologize for any inconvenience and will provide an update at the next change in status.
Posted Mar 21, 2020 - 09:34 PDT
Identified
We have identified an issue that is resulting in slower downloads for some users in the Asia-Pacific region. Box engineers are actively reviewing the issue and do not have an estimated time for resolution. We will post updates at the next change in status.
Posted Mar 20, 2020 - 07:30 PDT
This incident affected: Desktop Applications (Box Sync, Box Drive, Box Edit / Tools), Box Web Application (Uploads/Downloads), and Box Platform / API (Uploads/Downloads).