Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues accessing Box
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further issues have been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help
Posted 6 months ago. Feb 01, 2017 - 12:18 PST
Monitoring
Access to the Box Marketing Site (https://www.box.com) has been restored. Box Network Engineers are continuing to monitor services to ensure no further impact.
Posted 6 months ago. Feb 01, 2017 - 11:46 PST
Update
The Box Marketing site (https://www.box.com/home) remains intermittently inaccessible to some users due to localized ISP issue. Alternate login domains to access your Box account include https://app.box.com and https://account.box.com.
Posted 6 months ago. Feb 01, 2017 - 10:16 PST
Update
While an investigation continues, the main Box marketing site (https://www.box.com) appears to be seeing the largest impact of a blank page. Alternate login domains to access your Box account include https://app.box.com and https://account.box.com
Posted 6 months ago. Feb 01, 2017 - 09:03 PST
Identified
Due to a network link issue on the East Coast, some customers in limited regions may see issues accessing Box.com. While Box Network Engineers remediated the initial issue, there continues to be some limited impact that is being actively investigated at this time.
Posted 6 months ago. Feb 01, 2017 - 08:16 PST
This incident affected: Box Website.