For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Errors in Box Sign
Incident Report for Box
Postmortem

We recently addressed an issue affecting the use of Box Sign. We would like to take the opportunity to further explain this issue and the steps we have taken to keep it from happening in the future.

Between 2:40 AM and 12:42 PM PST on July 6, 2023, some users may have experienced difficulties while working in Box Sign. During this time, some users may have received an error message stating: "An error occurred, we have been notified of the issue. Please come back later and try again." The issue occurred as a result of a web application firewall ruleset update in our ongoing effort to continually improve security posture and reduce attack surface on our infrastructure. We are improving our testing processes and refining our alerting about issues that impact the user experience to prevent similar issues from occurring in the future.

Analysis

After a web application firewall ruleset update, some Box Sign requests were blocked by a broad pattern match. After identifying the issue, the ruleset was tuned to no longer block legitimate traffic.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Limitation of the affected product reported to the vendor and the advised mitigation applied.
  • Application testing process enhancement applied.
  • Issue alerting coverage extended and enhanced.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.  Thank you for being a Box customer.

Sincerely,

The Box Team

Posted Jul 18, 2023 - 09:34 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box Sign has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jul 06, 2023 - 13:32 PDT
Monitoring
Our team has taken steps to remediate this issue and is seeing improvement for Box Sign. We are continuing to monitor for any additional impact.
Posted Jul 06, 2023 - 12:43 PDT
Update
We are continuing to investigate this issue and will provide additional information as it becomes available.
Posted Jul 06, 2023 - 11:31 PDT
Update
We are continuing to investigate this issue and will provide additional information as it becomes available.
Posted Jul 06, 2023 - 10:11 PDT
Investigating
Our team is investigating an issue with Box Sign. Some users may see error messages when attempting to complete Box Sign requests. We will provide additional information as it becomes available.
Posted Jul 06, 2023 - 09:06 PDT
This incident affected: Box Web Application (Box Sign).