For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Logins

Incident Report for Box

Postmortem

We previously addressed an issue that impacted a small percentage of users utilizing multi-factor authentication (MFA) while logging into Box and accessing the Box API. We would like to take this opportunity to explain the issue and the steps we have taken to prevent similar occurrences in the future.

Incident Summary

On February 14, 2024, between 11:00 AM PST and 11:32 AM PST, some users may have experienced difficulties logging into Box and using the Box API when MFA was required. This issue was caused by a temporary failure in an underlying network component provided by one of our third-party service providers. The disruption was automatically resolved when the service provider mitigated the issue.

Analysis

The issue originated from a temporary failure within a regional infrastructure component of our service provider, which supports functions such as request handling, load balancing, and metadata storage. This system is designed to dynamically scale and adjust compute capacity in response to demand fluctuations. However, an unexpected spike in demand exceeded its ability to provision additional resources quickly, leading to increased latency and service errors across multiple services in the affected region.

As a result, authentication requests for MFA users on Box were impacted until the service provider was able to isolate and mitigate the issue.

Corrective Actions

To further enhance the resilience of our authentication services, we have implemented the following measures:

  • Improved alerting for load balancers to detect and respond to service degradations more effectively.
  • Assessment and implementation of direct fallback application profiles to minimize disruptions in the event of similar network-related failures.

We remain committed to delivering a reliable and secure experience for all Box users. We appreciate your patience and understanding and are happy to answer any further questions regarding this matter.

Sincerely,

The Box Team

Posted Feb 22, 2024 - 12:02 PST

Resolved

After further monitoring, this incident is now considered resolved. All logins have has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Feb 14, 2024 - 12:36 PST

Monitoring

Our team has taken steps to remediate this issue and the login service should be returning to full functionality. We are continuing to monitor for any additional impact.
Posted Feb 14, 2024 - 12:23 PST

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Feb 14, 2024 - 11:53 PST

Investigating

Our team is investigating an issue with Logins within Box. Users attempting to log in to Box may see errors or timeouts. We will provide additional information as it becomes available.
Posted Feb 14, 2024 - 11:22 PST
This incident affected: Box Web Application (Login/SSO) and Desktop Applications (Login/SSO).