Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
No further issues have been observed related to this event. All services have been restored.
Posted almost 2 years ago. Jan 13, 2016 - 14:25 PST
Monitoring
We have identified and resolved the source of the issue preventing some users from accessing the Box Web App. Currently monitoring.
Posted almost 2 years ago. Jan 13, 2016 - 13:12 PST
Investigating
The Box Web application may be unavailable to some users at this time. We are investigating and will keep you updated.
Posted almost 2 years ago. Jan 13, 2016 - 13:05 PST
This incident affected: Box Website.