For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Public API
Incident Report for Box
Postmortem

Between August 21, 2023 5:59 PM PDT, and August 21, 2023 7:04 PM PDT, some users may have experienced difficulties while working in Box. During this time, customers may have experienced delays when using Box Drive. We would like to take this opportunity to provide an analysis of this issue and the corrective actions we have taken in response.

Analysis

The issue occurred due to one of our services experiencing a surge in users from Box Drive This surge caused the service to run in a degraded state. At the root of this incident were capacity constraints that our existing servers could not adequately manage. We were able to resolve the issue by adding additional capacity to the service. Additionally, we have set up alerts designed to notify our on-call engineering team when server utilization approaches the set limits, allowing for immediate corrective action.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Capacity increase to ensure our servers can handle projected user traffic surges
  • Alerts to notify on-call engineering when servers are operating near its limit so corrective actions can be taken immediately

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Sep 06, 2023 - 11:53 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Aug 21, 2023 - 19:15 PDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Aug 21, 2023 - 19:05 PDT
Investigating
We are investigating an ongoing issue affecting Public API. We will provide more information as soon as it is available.
Posted Aug 21, 2023 - 18:31 PDT
This incident affected: Box Platform / API (Content API).