Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Crocodoc Service Unavailable
Incident Report for Box
Resolved
After monitoring, we have seen no further issues with Crocodoc. At this time the issue is fully resolved. If you experience any issues, please contact support at https://community.box.com
Posted almost 2 years ago. Sep 11, 2015 - 11:47 PDT
Monitoring
The Crocodoc service has been restored. Engineers will continue monitoring to ensure stability. Please report any new issues at https://support.box.com.
Posted almost 2 years ago. Sep 11, 2015 - 09:21 PDT
Investigating
The Crocodoc service is currently unavailable for many users. Our engineering teams are actively investigating.
Posted almost 2 years ago. Sep 11, 2015 - 08:41 PDT
This incident affected: Crocodoc.