For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Critical] Issue with generating Reports
Incident Report for Box
Postmortem

We recently addressed issues affecting Enterprise Reports. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 1:25am and 10:51am on July 13, 2021, some users may have experienced difficulties while working in Box. During this time, Enterprise Reports could not be generated. The issue occurred as a result of an image dependency that was reverted within one of our cloud vendors' environments. As a result, the service was temporarily unable to provision computational resources to execute the report jobs. We were able to resolve the issue by rebuilding the images. In addition, we are working to increase our monitoring sensitivity to such failures and reviewing our image lifecycles to prevent similar vendor issues from impacting customers in the future. 

Analysis 

One of Box's cloud vendors made a change to cloud compute dependencies that our Enterprise Reports image pipeline leverages as part of creating computational resources for job execution. After the next run of our image pipeline, the Enterprise Report job image included a failing dependency from our cloud vendor. After our cloud vendor reverted the problematic change and Box generated a new image, Box's Enterprise Reports were able to resume successfully.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Increase monitoring sensitivity to report-generation failures

  • Review image lifecycles to limit the potential impact of dependency changes

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jul 28, 2021 - 12:09 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jul 13, 2021 - 14:03 PDT
Update
We are seeing some recover in regards to the Reports being generated when exporting. We will continue to monitor the issue to assure recovery.
Posted Jul 13, 2021 - 13:17 PDT
Monitoring
We are seeing some recover in regards to the Reports being generated when exporting. We will continue to monitor the issue to assure recovery.
Posted Jul 13, 2021 - 12:10 PDT
Update
We are seeing that real time reporting is still available for the following reports: User Activity Report, Security logs. Users can view the report information by clicking 'View' when generating report.
Posted Jul 13, 2021 - 11:39 PDT
Investigating
We are currently investigating an issue that is impacting reporting as of July 13 01:00 PDT. Users may see delays in reports being generated and exported or they may see error. We advise that customers do not repeat export requests at this time. We will provide updates here as soon as they are available.
Posted Jul 13, 2021 - 11:15 PDT
This incident affected: Box Web Application (Admin Console & Functionality).