Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Internet Explorer users with a proxy configured may have problems using the Box web app.
Incident Report for Box
Resolved
At 10:50 am PST, our Engineering Team has resolved issues accessing the Box web app for Internet Explorer users with a proxy configured. If users continue to experience problems, please open a case at support.box.com.
Posted almost 3 years ago. Dec 03, 2014 - 11:27 PST
Update
Our engineers are continuing their investigation into this issue. As a workaround, impacted customers may try m.box.com until this is resolved.
Posted almost 3 years ago. Dec 03, 2014 - 10:19 PST
Investigating
Internet Explorer users with a proxy configured may have problems using the Box web app. Our engineers are investigating the issue.
Posted almost 3 years ago. Dec 03, 2014 - 02:14 PST
This incident affected: Box Website.