Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
We have not seen any further issues. This has been fully resolved.
Posted almost 2 years ago. Nov 09, 2015 - 14:26 PST
Monitoring
We have identified and resolved the source of the issue. Currently monitoring.
Posted almost 2 years ago. Nov 09, 2015 - 12:09 PST
Investigating
The Box Web application may be unavailable to some users at this time. We are investigating and will keep you updated.
Posted almost 2 years ago. Nov 09, 2015 - 12:01 PST
This incident affected: Box Website.