Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Admin Console unavailable for some Box users
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. Please report any outstanding issues to Box User Services via https://community.box.com/help
Posted 11 months ago. Sep 30, 2016 - 12:12 PDT
Monitoring
Engineering has identified and stabilized the issue. The team is continuing to monitor the issue to confirm no further impact.
Posted 11 months ago. Sep 30, 2016 - 11:34 PDT
Investigating
Some Admins and Co-Admins may experience some issues accessing the Box Admin Console. Engineering is currently investigating the issue.
Posted 11 months ago. Sep 30, 2016 - 09:07 PDT
This incident affected: Box Website.