Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Support.Box.Com is Unavailable for Some Customers
Incident Report for Box
Resolved
Access to the Box Help site at https://support.box.com has been restored.
Posted almost 3 years ago. Jan 30, 2015 - 11:40 PST
Identified
Some customers may be unable to access the Box Help site at https://support.box.com. We are actively working to restore access as soon as possible.
Posted almost 3 years ago. Jan 30, 2015 - 10:39 PST