Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some Users are Unable to Submit Support Cases on the Box Community
Incident Report for Box
Resolved
The web case submission workflow has been resolved. We apologize for any inconvenience.
Posted 11 months ago. Mar 29, 2016 - 21:25 PST
Update
Submitting support cases through the Box Community remains an intermittent problem. The root cause has been traced to a connectivity issue with a third-party integration. We are in close contact with this vendor to monitor their progress toward resolution.
Posted 11 months ago. Mar 29, 2016 - 14:50 PST
Identified
When attempting to submit a support case through the Box Community, some users may see "Error in template" and will unable to proceed further. We are actively investigating.
Posted 11 months ago. Mar 29, 2016 - 08:02 PST