Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box services degraded
Incident Report for Box
Resolved
All services returned to normal as of 4:50PM PDT. We apologize for any inconvenience.
Posted over 2 years ago. Oct 08, 2014 - 20:34 PST
Monitoring
Some customers may have had degraded experience with box services from 4:35PM - 4:50PM PDT. Services are currently functioning properly.
Posted over 2 years ago. Oct 08, 2014 - 16:50 PST
This incident affected: Box Website, Box Notes, Content Preview, Content API, View API, Downloads, Uploads, Search, Sharing, and Mobile.