About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Some Users Unable to Access Box Relay
Incident Report for Box
Resolved
Box Engineers have confirmed with IBM that issues with Box Relay are fully resolved. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help
Posted 10 months ago. Dec 15, 2017 - 11:10 PST
Identified
Box Engineering has identified the underlying cause of the issue and is actively working with IBM to remediate the impact to Box Relay.
Posted 10 months ago. Dec 15, 2017 - 11:03 PST
Investigating
Box Engineering is investigating an issue related to Box Relay. Users of this application may receive a 503 error when attempting to access the service.
Posted 10 months ago. Dec 15, 2017 - 10:49 PST