On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Box Uploads issue (5:15 PM Pacific to 5:30 PM Pacific)
Incident Report for Box
Resolved
We have identified and resolved the underlying cause of the upload issues from 5:15 PM Pacific to 5:30 PM Pacific today. No issues were observed outside of that timeframe.
If you are experiencing upload issues, please let us know at https://support.box.com.
Posted 3 months ago. Aug 15, 2018 - 20:31 PDT
Update
We are still investigating the upload issues from 5:15 PM Pacific to 5:30 PM Pacific today. No further impact has been observed outside of the timeframe.
There is no current impact to Box's Uploads services at this time.
Posted 3 months ago. Aug 15, 2018 - 19:09 PDT
Investigating
We are investigating an issue with our Uploads services that occurred from approximately 5:15 PM Pacific to 5:30 PM Pacific. A small subset of users may have seen issues uploading files during this time.

There is no current impact to Box's Uploads services at this time.
Posted 3 months ago. Aug 15, 2018 - 17:44 PDT