Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some Users May Experience Issues Loading Box Notes
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you are still experiencing issues, please contact the Box User Services team via https://community.box.com/help.
Posted 2 months ago. Aug 08, 2017 - 07:59 PDT
Monitoring
Box Engineers have pushed a fix to resolve the issue. We will monitor to ensure there is no further impact.
Posted 2 months ago. Aug 08, 2017 - 07:36 PDT
Investigating
Box Engineers are looking into an issue that may be preventing Box Notes from loading in the Box Web Application and Notes Desktop Application for some users.
Posted 2 months ago. Aug 08, 2017 - 06:49 PDT
This incident affected: Box Notes.