Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues logging into Box
Incident Report for Box
Resolved
No further impact has been observed by our engineering team. If you continue to experience any issues, please contact Box User Services via community.box.com
Posted 7 months ago. Oct 10, 2016 - 11:57 PDT
Monitoring
Box engineering has identified the issue and is currently monitoring to ensure no further impact.
Posted 7 months ago. Oct 10, 2016 - 11:43 PDT
Investigating
Some users may receive an error when logging into Box. Our engineering team is currently investigating issues with SSO logins.
Posted 7 months ago. Oct 10, 2016 - 10:53 PDT
This incident affected: Box Website.