For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Some Box Users May Be Experiencing Slow Page Loads and Failed Uploads
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help
Posted Jun 04, 2017 - 17:49 PDT
Monitoring
Box engineering teams have stabilized the issue with web application, upload, and conversation degradation. Engineering is continuing to monitor services to ensure no further impact is observed.
Posted Jun 04, 2017 - 17:16 PDT
Investigating
Box Engineering is currently investigating an issue with Uploads and Document Conversion/Preview. Document previews may not successfully load, and uploads may not successfully complete.
Posted Jun 04, 2017 - 16:33 PDT
This incident affected: Box Platform / API (Content API, Content Preview).