For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Outage] Issue with Box Notes
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Notes. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

On June 22, 2022 between 01:37pm PDT and 01:46pm PDT, some users may have experienced difficulties while working in Box. During this time, users may have had trouble accessing Box Notes.

Analysis

In connection with a planned update to Box Notes, certain traffic was inadvertently deployed to an incorrect data center. This caused users to temporarily encounter errors when trying to access Box Notes. We were able to resolve the issue by redeploying traffic to the correct data center. In addition, we are making changes to our documentation and building automated safeguards to prevent this issue from happening again in the future. 

Corrective Actions

The following corrective actions have been completed or are planned:

  • Updating internal processes and documentation to check for potential issues prior to deployment.
  • Incorporating additional automations to safeguard against incorrect deployments.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Jul 06, 2022 - 13:19 PDT

Resolved
From approximately 13:41-13:46 pm PT, users may have been unable to access Box Notes. Our team has identified the issue and worked on a fix so we are no longer seeing any impact in our metrics. If you are having an issue, please do not hesitate to submit a ticket at support.box.com!
Posted Jun 22, 2022 - 13:30 PDT