On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Search Indexing Delays
Incident Report for Box
Resolved
No further impact has been observed and we are considering the issue resolved. If you experience any new issues when searching for content, please let us know at https://support.box.com.
Posted 6 days ago. Nov 09, 2018 - 13:59 PST
Update
Customers should no longer be experiencing significant delays before a newly created or uploaded item is available for search. We are continuing to investigate the issue, and we will provide another update in one hour or when new information is available.
Posted 6 days ago. Nov 09, 2018 - 12:57 PST
Investigating
We are currently investigating an issue with search indexing. Beginning at approximately 10:00 AM Pacific time, users may have experienced delays of up to 30 minutes before items were available via search. We will provide an update in one hour or as soon as new information is available.
Posted 6 days ago. Nov 09, 2018 - 11:35 PST