For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Some Uploads and Downloads Slower Than Expected
Incident Report for Box
Postmortem

We recently addressed issues affecting login, upload, and download. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between March 17th at 12:41 AM and March 19th at 8:17 AM PDT, some users may have experienced difficulties while working in Box. During this time, a subset of users for some customers may have observed intermittent login failures, upload errors, and slow downloads. The issue occurred as a result of an external network maintenance by a third party provider who moved to a new switching platform for improved stability as part of their maintenance. We were able to resolve the issue by pushing a change to avoid the problematic network. In addition, we are working to improve our external network service monitoring to prevent similar issues from occurring in the future. 

Analysis 

This issue happened because a third party network provider performed a maintenance that caused a degradation to the network service for which we did not have a monitoring alert. Once the degradation was identified, we were able to re-route traffic around the problematic network path.    

Corrective Actions

The following corrective actions have been completed or are planned:

  • We will be working very closely with the third party network service provider on all future maintenances of the same type.

  • We will be creating new alerts that would detect network service degradation much sooner and well before they may impact customers

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jun 28, 2021 - 09:39 PDT

Resolved
We have concluded our monitoring window and no additional impact has been observed. We are considering the issue to be fully resolved. If you are encountering any new issues with upload or download performance, please contact Box Support at https://support.box.com.
Posted Mar 19, 2021 - 14:13 PDT
Monitoring
Our team has taken action that shows signs of remediation. We are continuing to monitor metrics and will provide additional information as it becomes available. If you are still encountering much slower upload or download performance than expected, please contact Box Support at https://support.box.com.
Posted Mar 19, 2021 - 10:00 PDT
Update
Our team is continuing to investigate this issue and take action to mitigate impact. We will provide additional information as it becomes available.
Posted Mar 19, 2021 - 09:03 PDT
Investigating
Our team is currently investigating an issue where some customers may currently experience slower uploads and downloads than expected. We will provide additional information as it becomes available.
Posted Mar 19, 2021 - 07:21 PDT
This incident affected: Box Web Application (Uploads/Downloads), Mobile Applications (Uploads/Downloads), and Box Platform / API (Uploads/Downloads).