Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] File Uploads Failing Intermittently
Incident Report for Box
Resolved
The issue with some file uploads failing has been resolved. Please report any issues to https://support.box.com.
Posted almost 2 years ago. May 05, 2015 - 16:29 PDT
Monitoring
This issue has been resolved, and we will continue to actively monitor. If you experience issues, please contact us at https://support.box.com.
Posted almost 2 years ago. May 05, 2015 - 14:35 PDT
Investigating
Some customers may be experiencing intermittent errors when uploading files, receiving error "There was an error with your upload, please try again."
Posted almost 2 years ago. May 05, 2015 - 13:55 PDT
This incident affected: Uploads.