For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] User May Encounter Issues Accessing Marketing Page box.com

Incident Report for Box

Resolved

This incident has now been resolved. Box will continue to monitor CloudFlare: https://www.cloudflarestatus.com/incidents/kwy3dt82bwbt
Posted Feb 20, 2026 - 12:37 PST

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement for our marketing page box.com. We are continuing to monitor for any additional impact.
Posted Feb 20, 2026 - 11:30 PST

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. The issue is due to an outage within Cloudflare at this time: https://www.cloudflarestatus.com/incidents/kwy3dt82bwbt

As we work on remediation steps users can workaround this issue by access box through app.box.com instead of box.com
Posted Feb 20, 2026 - 11:14 PST

Investigating

Our team is investigating an issue with the marketing site box.com. Users may see errors when attempting to access Box.
Posted Feb 20, 2026 - 11:11 PST
This incident affected: Box Web Application (Login/SSO) and Box Website.