On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues with Uploads
Incident Report for Box
Resolved
This issue is now considered resolved. The root cause was an underperforming file system. If you have issues uploading content to Box please contact us at https://support.box.com
Posted 20 days ago. Oct 26, 2018 - 16:21 PDT
Update
We are continuing to investigate an issue related to uploads to Box. Some users may see an error or increased latency when attempting to upload. The next update will be in 1 hour or at the next status update.
Posted 20 days ago. Oct 26, 2018 - 15:43 PDT
Update
We are still investigating and issue related to uploads to box. Some users may see an error or increased latency when attempting to upload. The next update will be in 1 hour or at the next status update.
Posted 20 days ago. Oct 26, 2018 - 14:30 PDT
Update
We are still investigating and issue related to uploads to box. Some users may see an error or increased latency when attempting to upload.
Posted 20 days ago. Oct 26, 2018 - 13:38 PDT
Update
There is no significant update to provide at this time. We are still investigating and issue related to uploads to box. Some users may see an error or increased latency when attempting to upload.
Posted 20 days ago. Oct 26, 2018 - 12:36 PDT
Update
We are still investigating and issue related to uploads to box. Some users may see an error or increased latency when attempting to upload.
Posted 20 days ago. Oct 26, 2018 - 11:49 PDT
Investigating
We are currently investigating an issue with uploads to box. Some users may experience errors when uploading content. We will provide more information here as it becomes available.
Posted 20 days ago. Oct 26, 2018 - 11:03 PDT
This incident affected: Box Platform / API (Content API) and Box Web Application (Uploads/Downloads).