For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Delays in Box Relay

Incident Report for Box

Postmortem

We recently addressed issues affecting Relay workflows. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between July 21, 2024, 3:00 PM PT and July 22, 2024, 2:00 AM PT, some users may have observed that some Relay workflows were delayed.

Analysis

Relay workflows are executed on a shared pool of compute resources. This issue occurred because the system was under unusually high load, which delayed the execution of some workflows. We were able to resolve the issue by rebalancing resources across outstanding workflows.

We are currently enhancing our monitoring and notification systems to ensure that engineers receive timely alerts about resource allocation issues. Additionally, we are focusing on improving our tools for rebalancing resources in order to proactively prevent similar issues from happening again in the future.

Corrective Actions

Box has initiated the following corrective actions:

  • Automatic recognition of workflow causing peak load and optimizing resource utilization.
  • Reducing time to action by improving engineering troubleshooting steps to diagnose and detect resource allocation issues that cause delays.
  • Improve internal tooling to allow quicker intervention for on-support specialists.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Oct 31, 2024 - 22:52 PDT

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jul 22, 2024 - 02:19 PDT

Identified

Box continues remediation efforts to restore full functionality to Box Relay. The underlying cause of the issue has been identified and efforts are underway to restore functionality.

Users of this service may continue to notice issues with relay workflows triggering while remediation is in process.
Posted Jul 22, 2024 - 01:03 PDT

Update

Box continues to investigate reports of issues with Relay Workflows not firing/processing. Impacted services include Box Relay.
Users of this service may experience Box Relay workflows coming to a stop or not triggering. We are diligently working on this. Thank you for your patience.
Posted Jul 21, 2024 - 23:50 PDT

Investigating

Our team are still investigating an issue regarding Box Relay. Users may observe delays in their Box Relay workflows. We will provide additional information as it becomes available.
Posted Jul 21, 2024 - 22:31 PDT
This incident affected: Box Relay.