After further monitoring, this incident is now considered resolved. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Oct 20, 2025 - 12:21 PDT
Monitoring
Steps have been taken to remediate this issue and SMS MFA should be returned to full functionality. We are continuing to monitor for any additional impact.
Posted Oct 20, 2025 - 11:48 PDT
Identified
Our team is working with a third party provider to remediate this issue and has identified the root cause. We will provide additional information as it becomes available.
Posted Oct 20, 2025 - 11:16 PDT
Investigating
Our team is investigating an issue with SMS MFA codes. Users may experience delays or failures when attempting to use SMS MFA. We will provide additional information as it becomes available.
Posted Oct 20, 2025 - 11:00 PDT
This incident affected: Box Web Application (Login/SSO), Desktop Applications (Login/SSO), and Mobile Applications (Login/SSO).