Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Slow Document Previews in the Web App
Incident Report for Box
Resolved
The monitoring period for this issue has expired and there have been no further identified issues.
Posted over 1 year ago. Dec 22, 2015 - 07:33 PST
Monitoring
Preview, Email Uploads, and Email Notifications are all working normally at this time. Engineering continues to monitor.
Posted over 1 year ago. Dec 21, 2015 - 16:50 PST
Update
Box Engineers are continuing their investigation of slow document preview. The issue is also impacting uploads by email and delivery of email notifications.
Posted over 1 year ago. Dec 21, 2015 - 09:46 PST
Investigating
Some customers may be experiencing slow document previews in the Web App. Our Engineers are currently investigating.
Posted over 1 year ago. Dec 21, 2015 - 09:00 PST
This incident affected: Box Website, Content Preview, Uploads, and Email Notifications.