For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Medium] Issues with File Requests

Incident Report for Box

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jul 23, 2026 - 04:42 PDT

Identified

The underlying cause of the issue has been identified and efforts are underway to restore stability. Box continues remediation efforts to fully restore the metadata functionality of File Requests.
Posted Jul 23, 2026 - 04:05 PDT

Investigating

We are investigating an ongoing issue affecting metadata updates using File Request. We will provide more information as soon as it is available.

Users of this service may face delays in metadata updates while attempting to upload files using File Request.
Posted Jul 23, 2026 - 02:45 PDT
This incident affected: Box Web Application (Sharing (Shared Links)).