For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with multiple Box services
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On April 22, 2024, between 5:35 PM and 7:20 PM PDT, some users may have experienced difficulties while working in Box. During this time, users may have experienced degradation of Public API, Login, Box Sign, Authorization, Uploads, Downloads, Notes, and Box For Office integrations. The issue occurred as a result of an infrastructure change intended to create additional dedicated infrastructure for one of our databases in a particular region. Due to a misconfiguration, this resulted in a disruptive node pool operation instead of an in-place update on the database cluster’s node pool. We were able to limit impact time and magnitude by creating a parallel node pool. When the disruptive operation completed, applications recovered automatically with some manual assistance. To prevent similar issues from occurring in the future we have a current ongoing project to refactor our configuration repositories so that granular changes do not create unrelated global changes.

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Apr 25, 2024 - 10:49 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Apr 22, 2024 - 19:33 PDT
Monitoring
We have resolved the issue impacting Box services. We are continuing to monitor to ensure no further impact is observed
Posted Apr 22, 2024 - 18:57 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2024 - 18:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2024 - 18:24 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 22, 2024 - 18:15 PDT
Investigating
Our team is investigating an issue with multiple Box services. Users attempting to use these services may see errors or timeouts. We will provide additional information as it becomes available.
Posted Apr 22, 2024 - 18:12 PDT
This incident affected: Box Platform / API (Content API, Uploads/Downloads), Box Web Application (Login/SSO, Uploads/Downloads, Sharing (Shared Links), Admin Console & Functionality, Box Sign), Desktop Applications (Login/SSO), Mobile Applications (Login/SSO, Uploads/Downloads), and Box Notes (Web Application).