For more informtion about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Third Party Outage Causing Delays in Email Generation
Incident Report for Box
Resolved
This issue is now being reported as resolved. Please contact Box Support via https://support.box.com if you are still experiencing any issues.
Posted Jan 23, 2020 - 13:25 PST
Identified
Our team has become aware of an issue reported by our third party mail provider. Some customers may experience delays when generating email notifications or password reset links. We will continue to relay updates as they are made available to us.
Posted Jan 23, 2020 - 12:20 PST