Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Duplicate Email Notifications Received by Some Customers
Incident Report for Box
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jul 30, 2015 - 11:29 PDT
Monitoring
The issue with multiple, duplicated email notifications has been stabilized. Box Engineering Teams are now monitoring to ensure no further impact.
Posted almost 2 years ago. Jul 30, 2015 - 09:23 PDT
Investigating
Some customers are receiving multiple, duplicated email notifications from "Box Updates". Box Engineering is currently investigating.
Posted almost 2 years ago. Jul 30, 2015 - 08:00 PDT
This incident affected: Email Notifications.